Benvenuto in gestionestandgastronomico Q&A, dove potrai porre quesiti e ricevere risposte da altri membri della community.

Errore apertura programma in rete

0 voti
Ciao,

ho provveduto ad installare il programma in rete.
Ho seguito tutte le procedure indicate nel manuale, inclusa l'installazione di postgres e la verifica dei file di conf.
avviando il programma da client si apre e tutto ok, mente da server non si apre e il log da questo errore:
2018-03-22 12:07:16,290 - sagra - ERROR - Uncaught exception:
Traceback (most recent call last):
  File "<string>", line 19, in <module>
  File "c:\python27\lib\site-packages\PyInstaller-2.1dev_71a4ce2-py2.7.egg\PyInstaller\loader\pyi_importers.py", line 270, in load_module
  File "C:\git\gestionesagra\src\build\sagra\out00-PYZ.pyz\splashscreen", line 5, in <module>
  File "c:\python27\lib\site-packages\PyInstaller-2.1dev_71a4ce2-py2.7.egg\PyInstaller\loader\pyi_importers.py", line 270, in load_module
  File "C:\git\gestionesagra\src\build\sagra\out00-PYZ.pyz\guiutil", line 3, in <module>
  File "c:\python27\lib\site-packages\PyInstaller-2.1dev_71a4ce2-py2.7.egg\PyInstaller\loader\pyi_importers.py", line 270, in load_module
  File "C:\git\gestionesagra\src\build\sagra\out00-PYZ.pyz\bo", line 4, in <module>
  File "c:\python27\lib\site-packages\PyInstaller-2.1dev_71a4ce2-py2.7.egg\PyInstaller\loader\pyi_importers.py", line 270, in load_module
  File "C:\git\gestionesagra\src\build\sagra\out00-PYZ.pyz\database", line 268, in <module>
  File "C:\git\gestionesagra\src\build\sagra\out00-PYZ.pyz\migrate.versioning.api", line 186, in upgrade
  File "<string>", line 2, in _migrate
  File "C:\git\gestionesagra\src\build\sagra\out00-PYZ.pyz\migrate.versioning.util", line 159, in with_engine
  File "C:\git\gestionesagra\src\build\sagra\out00-PYZ.pyz\migrate.versioning.api", line 345, in _migrate
  File "C:\git\gestionesagra\src\build\sagra\out00-PYZ.pyz\migrate.versioning.schema", line 80, in changeset
  File "C:\git\gestionesagra\src\build\sagra\out00-PYZ.pyz\migrate.versioning.repository", line 225, in changeset
  File "C:\git\gestionesagra\src\build\sagra\out00-PYZ.pyz\migrate.versioning.repository", line 189, in version
  File "C:\git\gestionesagra\src\build\sagra\out00-PYZ.pyz\migrate.versioning.version", line 140, in version
KeyError: <VerNum(16)>

Di cosa si tratta? grazie mille e buon lavoro
ciao
Nicola
quesito posto 22 Marzo da nicofolla (120 punti)

2 Risposte

0 voti
Qui c'è bisogno dell'aiuto di Emanuele. Lo avviso.
Ciao.

Mauro.
risposta inviata 22 Marzo da mrsmyle (22,440 punti)
ok, attendo news, grazie mille
0 voti
Ciao,

dall'errore sembra che tu stia usando una versione del database superiore rispetto a quella usata dal programma.

Stai provando a riutilizzare lo stesso database di una versione "superiore" ?

Ad esempio se inizialmente hai usato il programma alla versione 2.0.4  e poi riutilizzi lo stesso database con una versione più vecchia del programma potresti incorrere in questo errore. La retrocompatiblità del database non è prevista.

Il modo migliore per risolvere il problema è ripartire da zero col database; non serve reinstallarlo ma basta creare un nuovo database da pgAdmin e poi configurare il programma in modo che usi il nuovo database.

Spero di esserti stato d'aiuto.

Emanuele
risposta inviata 24 Marzo da emanuele (14,539 punti)
...